Back to overview
Resolved
Data serving slowness in Asia region
Jun 10, 2026 at 7:00am UTC
Affected services
AWS CDN
Resolved
Jun 10, 2026 at 10:50am UTC
Issue is solved, Asia traffic back to nominal bandwidth performances.
Affected services
Created
Jun 10, 2026 at 7:00am UTC
We are experiencing slowness on large file downloads in Asia region since 7AM UTC. This only affects downloads via the huggingface CLI. Root cause identified and mitigation in progress.
Affected services